using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{IF(?!.*{IF).*?}.*?{ENDIF}";
string input = @"{IF bla}Text 1{ELSEIF ble}Text 2 {IF bli}Text 2.1{ELSE blo}Text 2.1{ENDIF} Main text end{/ENDIF}
I just want to get
{IF bli}Text 2.1{ELSE blo}Text 2.1{ENDIF}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}