$re = '/{IF(?!.*{IF).*?}.*?{ENDIF}/';
$str = '{IF bla}Text 1{ELSEIF ble}Text 2 {IF bli}Text 2.1{ELSE blo}Text 2.1{ENDIF} Main text end{/ENDIF}
I just want to get
{IF bli}Text 2.1{ELSE blo}Text 2.1{ENDIF}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);