package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\..{2,})){2,}$`)
var str = `gmail.com.com.com
gmail.com.com.org
gmail.tv.tv
alongrepetitionlongrepetition
shortrepetitionon
gmail.bonbon
gmail.bonbon.bonbon
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}