re = /(?:(\..{2,})){2,}$/m
str = 'gmail.com.com.com
gmail.com.com.org
gmail.tv.tv
alongrepetitionlongrepetition
shortrepetitionon
gmail.bonbon
gmail.bonbon.bonbon
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end