using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@n1:)(.*?)(\s{1})";
string substitution = @"$1<BK>$2<$><\\n>";
string input = @"@d1:Министру энергетики Республики Беларусь
@n1:Каранкевичу Виктору Михайлoвичу
@a1:ул. К. Маркса, 14, 220050, г. Минск
@d1:Генеральному директору РУП «Белорусское телеграфное агентство»
@n1:Акулович Ирине Борисовне
@a1:ул. Кирова, 26, 220030, г. Минск
@d1:Первому заместителю генерального директора РУП «Белорусское телеграфное агентство»
@n1:Кирильчик Оксана Михайловна
@a1:ул. Кирова, 26, 220030, г. Минск
@d1:Заместителю генерального директора РУП «Белорусское телеграфное агентство»
@n1:Римашевский Станислав Антонович
@a1:ул. Кирова, 26, 220030, г. Минск
@d1:Заместителю генерального директора РУП «Белорусское телеграфное агентство» – главному редактору редакции газеты «7 дней»
@n1:Филипповская Наталья Здиславовна
@a1:ул. Энгельса, 30, 220030, г. Минск
@d1:Заместителю генерального директора – начальнику центра внешних коммуникаций РУП «Белорусское телеграфное агентство»
@n1:Чвей Марта Владимировна
@a1:ул. Кирова, 26, 220030, г. Минск
@d1:Заместителю генерального директора по идеологической работе РУП «Белорусское телеграфное агентство»
@n1:Адерихо Сергей Анатольевич
@a1:ул. Энгельса, 30, 220030, г. Минск
@d1:Заместителю главного редактора редакции визуальной информации РУП «Белорусское телеграфное агентство»
@n1:Иваницкий Владимир Георгиевич
@a1:ул. Энгельса, 30, 220030, г. Минск
@d1:Редактору редакции визуальной информации РУП «Белорусское телеграфное агентство»
@n1:Буфетова Ирина Алексеевна
@a1:ул. Энгельса, 30, 220030, г. Минск
@d1:Директору – главному редактору Издательского дома «Беларусь сегодня»
@n1:Жуку Дмитрию Александровичу
@a1:ул. Богдана Хмельницкого, 10-а, 220013, г. Минск
@d1:Генеральному директору телеканала «СТВ»
@n1:Луцкому Игорю Владимировичу
@a1:ул. Коммунистическая, 6, 220029, г. Минск
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}