using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# noqa(?:: (?P<codes>([A-Z][0-9]+(?:[,\s]+)?)+))?";
string input = @"# NOQA: F401,F502,D123";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}