re = /# noqa(?:: (?P<codes>([A-Z][0-9]+(?:[,\s]+)?)+))?/i
str = '# NOQA: F401,F502,D123'
# Print the match result
str.match(re) do |match|
puts match.to_s
end