package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)foo[ \.,\n]+bar`)
var str = `foo bar
foo
bar
foo,bar
foobar shouldn't match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}