$re = '/foo[ \.,\n]+bar/m';
$str = 'foo bar
foo
bar
foo,bar
foobar shouldn\'t match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);