package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{6}|\d{9})$`)
var str = `123456
1234567
123456789
123
1234
12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}