$re = '/^(\d{6}|\d{9})$/m';
$str = '123456
1234567
123456789
123
1234
12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);