using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([ab])[ab]*\1$";
string input = @"ab
ba
aba
bab
aaaa
bbbb
aaaaab
aaaaba
aabbbaa
abab
baba";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}