$re = '/^([ab])[ab]*\1$/m';
$str = 'ab
ba
aba
bab
aaaa
bbbb
aaaaab
aaaaba
aabbbaa
abab
baba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);