using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"jobno:\s*(\d+)\s*(.*?)(?=\s+jobno:|$)";
string input = @"jobno: 4859305 jobtype: ASSEMBLY name: BLUEBALLOON color: red jobno: 3995433 name: SNEAKYPETE jobtype: PKG texture: crunchy";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}