re = /jobno:\s*(\d+)\s*(.*?)(?=\s+jobno:|$)/m
str = 'jobno: 4859305 jobtype: ASSEMBLY name: BLUEBALLOON color: red jobno: 3995433 name: SNEAKYPETE jobtype: PKG texture: crunchy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end