const regex = new RegExp(',?\\s*\\"(\\\\.|[^\\"])+\\"\\s*:\\s*null', 'gm')
const str = `{"a": null}
{"a": 123, "b": null}
{"a": 123, "b": null, "c": "foo"}
{"a": 123, "b": null, "c": "foo", "blby\\"nazov": false}
{"a": 123, "b": null, "c": "foo", "blby\\"nazov\\"null hodnotou": null, "d": 1}
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);