re = /,?\s*\"(\\.|[^\"])+\"\s*:\s*null/m
str = '{"a": null}
{"a": 123, "b": null}
{"a": 123, "b": null, "c": "foo"}
{"a": 123, "b": null, "c": "foo", "blby\\"nazov": false}
{"a": 123, "b": null, "c": "foo", "blby\\"nazov\\"null hodnotou": null, "d": 1}
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result