use strict;
my $str = 'GQSD-65 : title
GQSD-65 title
01_Définitions-04_';
my $regex = qr/([A-Z]{1,9}-[0-9]{2,4}\s:?)|([0-9]{0,2}_.*-[0-9]{0,2}_)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}