package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([01234])?`)
var str = `2h 42min`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}