$re = '/([01234])?/m';
$str = '2h 42min';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);