$re = '~.*/\K[^_]+~m';
$str = '2019/01/01/07/556662_cba3a4fc-cb8f-4150-859f-5f21a38373d0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);