import re
regex = re.compile(r".*/\K[^_]+", flags=re.MULTILINE)
test_str = "2019/01/01/07/556662_cba3a4fc-cb8f-4150-859f-5f21a38373d0"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")