# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!\([^)]+\d{4}\))//gm;t' <<< "Text text text (Hung et al., 2020; Sung et al., 2021) text text"