const regex = /(?!\([^)]+\d{4}\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\([^)]+\\d{4}\\))', 'gm')
const str = `Text text text (Hung et al., 2020; Sung et al., 2021) text text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);