re = /(?:(?:(?!\1)()|\1 )(?:(?!\2)()fat|(?!\3)()cat)){2}/
str = 'My fat cat is sleeping.
My cat is lazy.
My aunt is fat.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end