#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+/\d+/\d+) +((1[0-2]|0?[1-9]):([0-5][0-9]) ?([AaPp][Mm]))(?= +\d)"
Local $sString = "of Los Angeles 12/19/2018 11:39 AM She" & @CRLF & _
"as a Unit 1/18/2019 8:30 AM 4 1."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")