re = /(\d+\/\d+\/\d+) +((1[0-2]|0?[1-9]):([0-5][0-9]) ?([AaPp][Mm]))(?= +\d)/m
str = 'of Los Angeles 12/19/2018 11:39 AM She
as a Unit 1/18/2019 8:30 AM 4 1.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end