$re = '~<span>.*?</span>(*SKIP)(*FAIL)
|
\d+~x';
$str = 'strings123[abc123<span>123</span>def<span>456</span>123]strings456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);