// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)<span>.*?</span>(*SKIP)(*FAIL)
|
\d+").unwrap();
let string = "strings123[abc123<span>123</span>def<span>456</span>123]strings456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}