re = /<span>.*?<\/span>(*SKIP)(*FAIL)
|
(?:
(?:\G(?!\A)|\[)
[^\d\]]*
(\d+)
[^\d\]]*
\K
)/x
str = 'strings123[abc123<span>123</span>def<span>456</span>123]strings456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end