// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<\n]*[\)\]`])[^()\n]*)big").unwrap();
let string = "Should Match:
I like `xx` big `xx` cakes
I like big cakes
I like `big cakes
I like big` cakes
I like xx big xx cakes
I like ` xx big xx cakes
I like xx big xx` cakes
I like `xx` big `xx` cakes
I like big cakes
I like ]big cakes
I like big] cakes
I like xx big xx cakes
I like ] xx big xx cakes
I like xx big xx] cakes
I like ]xx] big ]xx] cakes
I like big cakes
I like (big cakes
I like big) cakes
I like xx big xx cakes
I like ( xx big xx cakes
I like xx big xx) cakes
I like (xx) big (xx) cakes
Should not Match:
I like (big) cakes
I like (xx big xx) cakes";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}