#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((&&|<=|>=|<|>|!=|==|&|!)|([-+=]{1,2})|([.!?)}{;,(-]))|(else|if|float|int)|(\d[\d.]))"
Local $sString = "int a, b, c;" & @CRLF & _
"float d, e;" & @CRLF & _
"a = b = 5;" & @CRLF & _
"c = 6;" & @CRLF & _
"if ( a > b)" & @CRLF & _
"{" & @CRLF & _
"c = a - b;" & @CRLF & _
"e = d - 2.0;" & @CRLF & _
"}" & @CRLF & _
"else" & @CRLF & _
"{" & @CRLF & _
"d = e + 6.0;" & @CRLF & _
"b = a + c;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")