using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"weapon(?:(?!_[^\W_]{2}_)_[^\W_]+)*";
string input = @"econ/default_generated/weapon_knife_flip_so_night_medium
econ/default_generated/weapon_bayonet_hy_ocean_knife_medium
econ/default_generated/weapon_knife_gut_aq_blued_heavy
econ/default_generated/weapon_knife_karambit_hy_webs_medium
econ/default_generated/weapon_knife_m9_bayonet_so_night_lightasd
econ/default_generated/weapon_knife_tactical_hy_ddpat_light
econ/default_generated/weapon_knife_falchion_aa_fade_heavy
econ/default_generated/weapon_knife_survival_bowie_am_doppler_phase3_heavy
econ/default_generated/weapon_knife_butterfly_hy_ddpat_medium
econ/default_generated/weapon_knife_push_hy_ddpat_light";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}