import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "weapon(?:(?!_[^\\W_]{2}_)_[^\\W_]+)*";
final String string = "econ/default_generated/weapon_knife_flip_so_night_medium\n"
+ "econ/default_generated/weapon_bayonet_hy_ocean_knife_medium\n"
+ "econ/default_generated/weapon_knife_gut_aq_blued_heavy\n"
+ "econ/default_generated/weapon_knife_karambit_hy_webs_medium\n"
+ "econ/default_generated/weapon_knife_m9_bayonet_so_night_lightasd\n"
+ "econ/default_generated/weapon_knife_tactical_hy_ddpat_light\n"
+ "econ/default_generated/weapon_knife_falchion_aa_fade_heavy\n"
+ "econ/default_generated/weapon_knife_survival_bowie_am_doppler_phase3_heavy\n"
+ "econ/default_generated/weapon_knife_butterfly_hy_ddpat_medium\n"
+ "econ/default_generated/weapon_knife_push_hy_ddpat_light";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}