import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^[:graph:]*](?#Do not match on any visible character)\n"
+ "\\K\\*(?#Reset starting point and then match on a *)\n"
+ "([[:alpha:].,\\ ]+(?:\\*{2}[[:alpha:].,\\ ]+\\*{2}?\\ ?)?)(*COMMIT)\n"
+ "\\*\\ ?(?#Match on ending * then stop matching with COMMIT)";
final String string = "This text is not italic.\n"
+ "*This text is italic.*\n"
+ "This text is *partially* italic\n"
+ "This text has *two* *italic* bits\n"
+ "**bold text (not italic)**\n"
+ "**bold text with *italic* **\n"
+ "**part bold,** *part italic*\n"
+ "*italic text **with bold** *\n"
+ "*italic* **bold** *italic* **bold**\n"
+ "*invalid markdown (do not parse)**\n"
+ "random * asterisk";
final String subst = "<i>$1</i> ";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}