import re
regex = re.compile(r"""
[^[:graph:]*](?#Do not match on any visible character)
\K\*(?#Reset starting point and then match on a *)
([[:alpha:].,\ ]+(?:\*{2}[[:alpha:].,\ ]+\*{2}?\ ?)?)(*COMMIT)
\*\ ?(?#Match on ending * then stop matching with COMMIT)
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("This text is not italic.\n"
"*This text is italic.*\n"
"This text is *partially* italic\n"
"This text has *two* *italic* bits\n"
"**bold text (not italic)**\n"
"**bold text with *italic* **\n"
"**part bold,** *part italic*\n"
"*italic text **with bold** *\n"
"*italic* **bold** *italic* **bold**\n"
"*invalid markdown (do not parse)**\n"
"random * asterisk")
subst = "<i>$1</i> "
result = regex.sub(subst, test_str)
if result:
print(result)