package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Я\s|\sЯ\s|^Я$|\sЯ$|^я\s|\sя\s|^я$|\sя$`)
var str = `Я красивая, но ужасная.
Я безвредная, но опасная.
Очень смелая, но трусливая.
Я несчастная, но счастливая.
Я холодная, но очень жгучая.
Молчаливая, но крикучая.
Я блондинка такая вся - черно-рыжая.
Я стеснительная, но бесстыжая.
Я нашла себя, но я пропащая!
Я безгрешная, но гулящая!
И я - не я, когда люблю.
Припев:
Я закрою дверь за тобою - не уходи.
Я закрою дверь за тобою.
Я никогда не прощу тебя или прощу я.
Нет, я тебя не люблю или может люблю тебя.
Я довольна собой? Да, я довольна собой.
Мне не надо другой - не такой, никакой.
Мне бы вдаль от земли, мне - куда облака.
Я пока еще не понимаю куда.
Ну, скажите тогда, как мне бедной прожить,
Если бедная я, но богатая я?
Я красивая, но ужасная.
Я безвредная, но опасная.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}