import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Я\\s|\\sЯ\\s|^Я$|\\sЯ$|^я\\s|\\sя\\s|^я$|\\sя$";
final String string = "Я красивая, но ужасная.\n"
+ "Я безвредная, но опасная.\n"
+ "Очень смелая, но трусливая.\n"
+ "Я несчастная, но счастливая.\n\n"
+ "Я холодная, но очень жгучая.\n"
+ "Молчаливая, но крикучая.\n"
+ "Я блондинка такая вся - черно-рыжая.\n"
+ "Я стеснительная, но бесстыжая.\n\n"
+ "Я нашла себя, но я пропащая!\n"
+ "Я безгрешная, но гулящая!\n"
+ "И я - не я, когда люблю.\n\n"
+ "Припев:\n"
+ "Я закрою дверь за тобою - не уходи.\n"
+ "Я закрою дверь за тобою.\n"
+ "Я никогда не прощу тебя или прощу я.\n"
+ "Нет, я тебя не люблю или может люблю тебя.\n\n"
+ "Я довольна собой? Да, я довольна собой.\n"
+ "Мне не надо другой - не такой, никакой.\n"
+ "Мне бы вдаль от земли, мне - куда облака.\n"
+ "Я пока еще не понимаю куда.\n\n"
+ "Ну, скажите тогда, как мне бедной прожить,\n"
+ "Если бедная я, но богатая я?\n"
+ "Я красивая, но ужасная.\n"
+ "Я безвредная, но опасная.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}