const regex = /^(?:[A-Z]{4}[0-9]{4}|[A-Z]{6}[0-9]{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[A-Z]{4}[0-9]{4}|[A-Z]{6}[0-9]{2})$', 'gm')
const str = `ABCD1234
PQRSTU88
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}