$re = '/^(?:[A-Z]{4}[0-9]{4}|[A-Z]{6}[0-9]{2})$/m';
$str = 'ABCD1234
PQRSTU88
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);