package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\S\r\n]*[^\s-].*(--)`)
var str = `-- BOL
test; -- C1
test => -- C1
-- BOL indent`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}