re = /^[^\S\r\n]*[^\s-].*(--)/m
str = '-- BOL
test; -- C1
test => -- C1
-- BOL indent'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end