#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?!(^$|[-]{1}[.]{1}|[0]{1}[0-9]+|[-]{1}[0]{1}[0-9]+))([\-]{0,1}[1-9]?[0-9]*((\.|\,)[0-9]*)?|[0]((\.|\,)[0-9]*)?)$"
Local $sString = "-0.123122342765172635778687"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")