$re = '@[\x27<>()\x22]@';
$str = '"<test>.html
(somethingevil
\'okthis/is/evil/url';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);