#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<picture"
Local $sString = " " & @CRLF & _
"<perfomer>" & @CRLF & _
" <picture0>" & @CRLF & _
" data1" & @CRLF & _
" </picture0>" & @CRLF & _
" <picture1>" & @CRLF & _
" data2" & @CRLF & _
" </picture1>" & @CRLF & _
" <picture2>" & @CRLF & _
" data3" & @CRLF & _
" </picture2>" & @CRLF & _
" ..." & @CRLF & _
" <picture100>" & @CRLF & _
" data101" & @CRLF & _
" </picture100>" & @CRLF & _
" <picture101>" & @CRLF & _
" data102" & @CRLF & _
" </picture101>" & @CRLF & _
" etc..." & @CRLF & _
"</performer>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")