$re = '/<picture/m';
$str = '
<perfomer>
<picture0>
data1
</picture0>
<picture1>
data2
</picture1>
<picture2>
data3
</picture2>
...
<picture100>
data101
</picture100>
<picture101>
data102
</picture101>
etc...
</performer>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);