const regex = new RegExp('(?:.*?)\\b(?P<search_term>(?:elder(?:ly)*|(?:young|old)(?:er)*|seniors*(?: citizens*)*|immuno[- ]*(?:suppressed|compromised)|youth))\\b(?:.*?)', 'gi')
const str = `immunosuppressed and elderly senior citizens and young or younger persons (youth) are immuno-compromised`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}