$re = '/(?:.*?)\b(?P<search_term>(?:elder(?:ly)*|(?:young|old)(?:er)*|seniors*(?: citizens*)*|immuno[- ]*(?:suppressed|compromised)|youth))\b(?:.*?)/i';
$str = 'immunosuppressed and elderly senior citizens and young or younger persons (youth) are immuno-compromised';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);