import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)$(?:\\n\\1)+";
final String string = "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "operator.livrareflori.md\n"
+ "amazon.de\n"
+ "fonts.gstatic.com\n"
+ "fonts.gstatic.com\n"
+ "fonts.gstatic.com\n"
+ "erovoyeurism.net\n"
+ "tugtechnologyandbusiness.com";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}