import re
regex = re.compile(r"^(.+)$(?:\n\1)+", flags=re.MULTILINE)
test_str = ("operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"operator.livrareflori.md\n"
"amazon.de\n"
"fonts.gstatic.com\n"
"fonts.gstatic.com\n"
"fonts.gstatic.com\n"
"erovoyeurism.net\n"
"tugtechnologyandbusiness.com")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)